CVE-2024-2961

NameCVE-2024-2961
DescriptionThe iconv() function in the GNU C Library versions 2.39 and older may overflow the output buffer passed to it by up to 4 bytes when converting strings to the ISO-2022-CN-EXT character set, which may be used to crash an application or overwrite a neighbouring variable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3807-1, DSA-5673-1
Debian Bugs1069191

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glibc (PTS)buster2.28-10+deb10u1vulnerable
buster (security)2.28-10+deb10u3fixed
bullseye2.31-13+deb11u8vulnerable
bullseye (security)2.31-13+deb11u10fixed
bookworm2.36-9+deb12u4vulnerable
bookworm (security)2.36-9+deb12u7fixed
trixie2.38-10fixed
sid2.38-11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glibcsourcebuster2.28-10+deb10u3DLA-3807-1
glibcsourcebullseye2.31-13+deb11u9DSA-5673-1
glibcsourcebookworm2.36-9+deb12u6DSA-5673-1
glibcsource(unstable)2.37-181069191

Notes

https://www.openwall.com/lists/oss-security/2024/04/17/9
https://www.openwall.com/lists/oss-security/2024/04/18/4
https://sourceware.org/git/?p=glibc.git;a=blob;f=advisories/GLIBC-SA-2024-0004
Introduced by: https://sourceware.org/git?p=glibc.git;a=commit;h=755104edc75c53f4a0e7440334e944ad3c6b32fc (cvs/libc-2_1_94)
Fixed by: https://sourceware.org/git?p=glibc.git;a=commit;h=f9dc609e06b1136bb0408be9605ce7973a767ada

Search for package or bug name: Reporting problems