CVE-2024-29864

NameCVE-2024-29864
DescriptionDistrobox before 1.7.0.1 allows attackers to execute arbitrary code via command injection into exported executables.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
distrobox (PTS)bookworm1.4.2.1-1vulnerable
trixie, sid1.7.1.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
distroboxsource(unstable)1.7.0.1-1

Notes

[bookworm] - distrobox <no-dsa> (Minor issue)
https://github.com/89luca89/distrobox/issues/1275
Fixed by: https://github.com/89luca89/distrobox/commit/82a69f0a234e73e447d0ea8c8b3443b84fd31944 (1.7.0.1)

Search for package or bug name: Reporting problems