CVE-2024-29944

NameCVE-2024-29944
DescriptionAn attacker was able to inject an event handler into a privileged object that would allow arbitrary JavaScript execution in the parent process. Note: This vulnerability affects Desktop Firefox only, it does not affect mobile versions of Firefox. This vulnerability affects Firefox < 124.0.1 and Firefox ESR < 115.9.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3775-1, DSA-5645-1
Debian Bugs1067523

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid125.0.1-1fixed
firefox-esr (PTS)buster91.12.0esr-1~deb10u1vulnerable
buster (security)115.9.1esr-1~deb10u1fixed
bullseye115.7.0esr-1~deb11u1vulnerable
bullseye (security)115.10.0esr-1~deb11u1fixed
bookworm115.7.0esr-1~deb12u1vulnerable
bookworm (security)115.10.0esr-1~deb12u1fixed
trixie115.8.0esr-1vulnerable
sid115.10.0esr-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)124.0.1-11067523
firefox-esrsourcebuster115.9.1esr-1~deb10u1DLA-3775-1
firefox-esrsourcebullseye115.9.1esr-1~deb11u1DSA-5645-1
firefox-esrsourcebookworm115.9.1esr-1~deb12u1DSA-5645-1
firefox-esrsource(unstable)115.9.1esr-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2024-15/#CVE-2024-29944
https://www.mozilla.org/en-US/security/advisories/mfsa2024-16/#CVE-2024-29944

Search for package or bug name: Reporting problems