CVE-2024-30203

NameCVE-2024-30203
DescriptionIn Emacs before 29.3, Gnus treats inline MIME contents as trusted.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1067630

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
emacs (PTS)buster1:26.1+1-3.2+deb10u2vulnerable
buster (security)1:26.1+1-3.2+deb10u4vulnerable
bullseye1:27.1+1-3.1+deb11u1vulnerable
bullseye (security)1:27.1+1-3.1+deb11u2vulnerable
bookworm1:28.2+1-15vulnerable
trixie1:29.2+1-2vulnerable
sid1:29.3+1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
emacssource(unstable)1:29.3+1-11067630

Notes

https://www.openwall.com/lists/oss-security/2024/03/24/1
https://lists.gnu.org/archive/html/info-gnu/2024-03/msg00005.html
https://git.savannah.gnu.org/cgit/emacs.git/commit/?h=emacs-29&id=937b9042ad7426acdcca33e3d931d8f495bdd804

Search for package or bug name: Reporting problems