CVE-2024-30204

NameCVE-2024-30204
DescriptionIn Emacs before 29.3, LaTeX preview is enabled by default for e-mail attachments.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3801-1, DLA-3802-1
Debian Bugs1067630, 1067663

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
emacs (PTS)buster1:26.1+1-3.2+deb10u2vulnerable
buster (security)1:26.1+1-3.2+deb10u5fixed
bullseye1:27.1+1-3.1+deb11u1vulnerable
bullseye (security)1:27.1+1-3.1+deb11u2vulnerable
bookworm1:28.2+1-15vulnerable
sid, trixie1:29.3+1-3fixed
org-mode (PTS)buster9.1.14+dfsg-3vulnerable
buster (security)9.1.14+dfsg-3+deb10u2fixed
bullseye9.4.0+dfsg-1+deb11u1vulnerable
bookworm9.5.2+dfsh-5vulnerable
sid, trixie9.6.28+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
emacssourcebuster1:26.1+1-3.2+deb10u5DLA-3801-1
emacssource(unstable)1:29.3+1-11067630
org-modesourcebuster9.1.14+dfsg-3+deb10u2DLA-3802-1
org-modesource(unstable)9.6.23+dfsg-11067663

Notes

[bookworm] - emacs <no-dsa> (Minor issue, will be fixed via point release)
[bullseye] - emacs <no-dsa> (Minor issue, will be fixed via point release)
[bookworm] - org-mode <ignored> (Produces only a dependency binary package)
[bullseye] - org-mode <no-dsa> (Minor issue; can be fixed via point release)
https://www.openwall.com/lists/oss-security/2024/03/24/1
https://lists.gnu.org/archive/html/info-gnu/2024-03/msg00005.html
https://git.savannah.gnu.org/cgit/emacs.git/commit/?h=emacs-29&id=6f9ea396f49cbe38c2173e0a72ba6af3e03b271c (emacs-29.3)
org-mode/9.5.2+dfsh-5 dropped all lisp files from the produced binary packages
making an empty dependency package only.

Search for package or bug name: Reporting problems