CVE-2024-31031

NameCVE-2024-31031
DescriptionAn issue in `coap_pdu.c` in libcoap 4.3.4 allows attackers to cause undefined behavior via a sequence of messages leading to unsigned integer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1070362

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcoap (PTS)buster4.1.2-1fixed
libcoap2 (PTS)buster4.2.0-2fixed
bullseye4.2.1-1fixed
libcoap3 (PTS)bookworm4.3.1-1vulnerable
sid, trixie4.3.4-1.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcoapsource(unstable)(not affected)
libcoap2source(unstable)(not affected)
libcoap3source(unstable)(unfixed)1070362

Notes

- libcoap <not-affected> (Vulnerable code not present)
- libcoap2 <not-affected> (Vulnerable code not present)
[bookworm] - libcoap3 <no-dsa> (Minor issue)
https://github.com/obgm/libcoap/issues/1351
https://github.com/obgm/libcoap/commit/214665ac4b44b1b6a7e38d4d6907ee835a174928 (develop)
Introduced by: https://github.com/obgm/libcoap/commit/7033555d2978b8d4d5e16d43cfbfe1b1781c418f (v4.3.0-rc1)
Introduced by: https://github.com/obgm/libcoap/commit/47a83549a80dad9a83f84cdfaba54c54defb5444 (v4.3.2-rc1)

Search for package or bug name: Reporting problems