CVE-2024-31443

NameCVE-2024-31443
DescriptionCacti provides an operational monitoring and fault management framework. Prior to 1.2.27, some of the data stored in `form_save()` function in `data_queries.php` is not thoroughly checked and is used to concatenate the HTML statement in `grow_right_pane_tree()` function from `lib/html.php` , finally resulting in cross-site scripting. Version 1.2.27 contains a patch for the issue.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)buster1.2.2+ds1-2+deb10u4vulnerable
buster (security)1.2.2+ds1-2+deb10u6vulnerable
bullseye1.2.16+ds1-2+deb11u2vulnerable
bullseye (security)1.2.16+ds1-2+deb11u3vulnerable
bookworm1.2.24+ds1-1+deb12u1vulnerable
bookworm (security)1.2.24+ds1-1+deb12u2vulnerable
sid, trixie1.2.27+ds1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisource(unstable)1.2.27+ds1-1

Notes

https://github.com/Cacti/cacti/security/advisories/GHSA-rqc8-78cm-85j3
https://github.com/Cacti/cacti/commit/f946fa537d19678f938ddbd784a10e3290d275cf

Search for package or bug name: Reporting problems