CVE-2024-32041

NameCVE-2024-32041
DescriptionFreeRDP is a free implementation of the Remote Desktop Protocol. FreeRDP based clients that use a version of FreeRDP prior to 3.5.0 or 2.11.6 are vulnerable to out-of-bounds read. Versions 3.5.0 and 2.11.6 patch the issue. As a workaround, deactivate `/gfx` (on by default, set `/bpp` or `/rfx` options instead.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1069728

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freerdp2 (PTS)buster2.0.0~git20190204.1.2693389a+dfsg1-1+deb10u2vulnerable
buster (security)2.3.0+dfsg1-2+deb10u4vulnerable
bullseye2.3.0+dfsg1-2+deb11u1vulnerable
bookworm2.10.0+dfsg1-1vulnerable
trixie, sid2.11.5+dfsg1-1vulnerable
freerdp3 (PTS)trixie3.5.1+dfsg1-3fixed
sid3.5.1+dfsg1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freerdp2source(unstable)(unfixed)1069728
freerdp3source(unstable)(not affected)

Notes

- freerdp3 <not-affected> (Fixed with initial upload to Debian unstable)
https://www.freerdp.com/2024/04/17/2_11_6-release
https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-5r4p-mfx2-m44r
https://github.com/FreeRDP/FreeRDP/commit/d88ad1acd142769650a6159906ac90f46a766265 (2.11.6)

Search for package or bug name: Reporting problems