CVE-2024-32658

NameCVE-2024-32658
DescriptionFreeRDP is a free implementation of the Remote Desktop Protocol. FreeRDP based clients prior to version 3.5.1 are vulnerable to out-of-bounds read. Version 3.5.1 contains a patch for the issue. No known workarounds are available.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1069752

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freerdp2 (PTS)buster2.0.0~git20190204.1.2693389a+dfsg1-1+deb10u2vulnerable
buster (security)2.3.0+dfsg1-2+deb10u4vulnerable
bullseye2.3.0+dfsg1-2+deb11u1vulnerable
bookworm2.10.0+dfsg1-1vulnerable
sid, trixie2.11.5+dfsg1-1vulnerable
freerdp3 (PTS)trixie3.5.1+dfsg1-3fixed
sid3.5.1+dfsg1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freerdp2source(unstable)(unfixed)
freerdp3source(unstable)3.5.1+dfsg1-11069752

Notes

https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-vpv3-m3m9-4c2v
Fixed by: https://github.com/FreeRDP/FreeRDP/commit/1a755d898ddc028cc818d0dd9d49d5acff4c44bf (3.5.1)

Search for package or bug name: Reporting problems