CVE-2024-34083

NameCVE-2024-34083
Descriptionaiosmptd is a reimplementation of the Python stdlib smtpd.py based on asyncio. Prior to version 1.4.6, servers based on aiosmtpd accept extra unencrypted commands after STARTTLS, treating them as if they came from inside the encrypted connection. This could be exploited by a man-in-the-middle attack. Version 1.4.6 contains a patch for the issue.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1072119

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-aiosmtpd (PTS)buster1.2-3vulnerable
bullseye1.2.2-1vulnerable
bookworm1.4.3-1.1vulnerable
sid, trixie1.4.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-aiosmtpdsource(unstable)1.4.6-11072119

Notes

[bookworm] - python-aiosmtpd <no-dsa> (Minor issue)
[bullseye] - python-aiosmtpd <no-dsa> (Minor issue)
[buster] - python-aiosmtpd <postponed> (Minor issue)
https://github.com/aio-libs/aiosmtpd/security/advisories/GHSA-wgjv-9j3q-jhg8
https://github.com/aio-libs/aiosmtpd/commit/b3a4a2c6ecfd228856a20d637dc383541fcdbfda (v1.4.6)

Search for package or bug name: Reporting problems