DescriptionComposer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the `status`, `reinstall` and `remove` commands with packages installed from source via git containing specially crafted branch names in the repository can be used to execute code. Patches for this issue are available in version 2.2.24 for 2.2 LTS or 2.7.7 for mainline. As a workaround, avoid installing dependencies via git by using `--prefer-dist` or the `preferred-install: dist` config setting.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1073125

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
composer (PTS)buster1.8.4-1+deb10u2vulnerable
buster (security)1.8.4-1+deb10u3vulnerable
bullseye (security)2.0.9-2+deb11u2vulnerable
bookworm (security)2.5.5-1+deb12u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs

Notes (2.2.24) (2.7.7)

Search for package or bug name: Reporting problems