CVE-2024-35242

NameCVE-2024-35242
DescriptionComposer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the `composer install` command running inside a git/hg repository which has specially crafted branch names can lead to command injection. This requires cloning untrusted repositories. Patches are available in version 2.2.24 for 2.2 LTS or 2.7.7 for mainline. As a workaround, avoid cloning potentially compromised repositories.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1073126

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
composer (PTS)buster1.8.4-1+deb10u2vulnerable
buster (security)1.8.4-1+deb10u3vulnerable
bullseye2.0.9-2+deb11u1vulnerable
bullseye (security)2.0.9-2+deb11u2vulnerable
bookworm2.5.5-1vulnerable
bookworm (security)2.5.5-1+deb12u1vulnerable
trixie2.7.6-3vulnerable
sid2.7.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
composersource(unstable)2.7.7-11073126

Notes

https://github.com/composer/composer/security/advisories/GHSA-v9qv-c7wm-wgmf
https://github.com/composer/composer/commit/fc57b93603d7d90b71ca8ec77b1c8a9171fdb467 (2.2.24)
https://github.com/composer/composer/commit/6bd43dff859c597c09bd03a7e7d6443822d0a396 (2.7.7)

Search for package or bug name: Reporting problems