CVE-2024-36039

NameCVE-2024-36039
DescriptionPyMySQL through 1.1.0 allows SQL injection if used with untrusted JSON input because keys are not escaped by escape_dict.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3822-1, DSA-5700-1
Debian Bugs1071628

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-pymysql (PTS)buster0.9.3-1vulnerable
buster (security)0.9.3-1+deb10u1fixed
bullseye0.9.3-2vulnerable
bullseye (security)0.9.3-2+deb11u1fixed
bookworm1.0.2-2vulnerable
bookworm (security)1.0.2-2+deb12u1fixed
sid, trixie1.1.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-pymysqlsourcebuster0.9.3-1+deb10u1DLA-3822-1
python-pymysqlsourcebullseye0.9.3-2+deb11u1DSA-5700-1
python-pymysqlsourcebookworm1.0.2-2+deb12u1DSA-5700-1
python-pymysqlsource(unstable)1.1.1-11071628

Notes

https://github.com/advisories/GHSA-v9hf-5j83-6xpp
https://github.com/PyMySQL/PyMySQL/commit/521e40050cb386a499f68f483fefd144c493053c (v1.1.1)

Search for package or bug name: Reporting problems