CVE-2024-3727

NameCVE-2024-3727
DescriptionA flaw was found in the github.com/containers/image library. This flaw allows attackers to trigger unexpected authenticated registry accesses on behalf of a victim user, causing resource exhaustion, local path traversal, and other attacks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1070858

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-github-opencontainers-go-digest (PTS)buster1.0.0~rc1-1vulnerable
bullseye1.0.0-1vulnerable
sid, trixie, bookworm1.0.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-github-opencontainers-go-digestsource(unstable)(unfixed)1070858

Notes

[bookworm] - golang-github-opencontainers-go-digest <no-dsa> (Minor issue)
[bullseye] - golang-github-opencontainers-go-digest <no-dsa> (Minor issue)
[buster] - golang-github-opencontainers-go-digest <postponed> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=2274767

Search for package or bug name: Reporting problems