CVE-2024-37370

NameCVE-2024-37370
DescriptionIn MIT Kerberos 5 (aka krb5) before 1.21.3, an attacker can modify the plaintext Extra Count field of a confidential GSS krb5 wrap token, causing the unwrapped token to appear truncated to the application.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5726-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)bullseye1.18.3-6+deb11u4vulnerable
bullseye (security)1.18.3-6+deb11u5fixed
bookworm1.20.1-2+deb12u1vulnerable
bookworm (security)1.20.1-2+deb12u2fixed
trixie1.21.2-1vulnerable
sid1.21.3-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5sourcebullseye1.18.3-6+deb11u5DSA-5726-1
krb5sourcebookworm1.20.1-2+deb12u2DSA-5726-1
krb5source(unstable)1.21.3-1

Notes

https://github.com/krb5/krb5/commit/55fbf435edbe2e92dd8101669b1ce7144bc96fef (krb5-1.21.3-final)

Search for package or bug name: Reporting problems