CVE-2024-37407

NameCVE-2024-37407
DescriptionLibarchive before 3.7.4 allows name out-of-bounds access when a ZIP archive has an empty-name file and mac-ext is enabled. This occurs in slurp_central_directory in archive_read_support_format_zip.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1072855

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libarchive (PTS)buster3.3.3-4+deb10u1fixed
buster (security)3.3.3-4+deb10u3fixed
bullseye3.4.3-2+deb11u1vulnerable
bookworm3.6.2-1vulnerable
bookworm (security)3.6.2-1+deb12u1vulnerable
sid, trixie3.7.2-2.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libarchivesourcebuster(not affected)
libarchivesource(unstable)(unfixed)1072855

Notes

[bookworm] - libarchive <no-dsa> (Minor issue)
[bullseye] - libarchive <no-dsa> (Minor issue)
[buster] - libarchive <not-affected> (The vulnerable code was introduced later)
https://github.com/libarchive/libarchive/pull/2145
https://github.com/libarchive/libarchive/commit/b6a979481b7d77c12fa17bbed94576b63bbcb0c0 (v3.7.4)

Search for package or bug name: Reporting problems