CVE-2024-37408

NameCVE-2024-37408
Descriptionfprintd through 1.94.3 lacks a security attention mechanism, and thus unexpected actions might be authorized by "auth sufficient pam_fprintd.so" for Sudo. NOTE: the supplier disputes this because they believe issue resolution would involve modifying the PAM configuration to restrict pam_fprintd.so to front-ends that implement a proper attention mechanism, not modifying pam_fprintd.so or fprintd.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1072854

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fprintd (PTS)buster0.8.1-1vulnerable
bullseye1.90.9-1vulnerable
bookworm1.94.2-2vulnerable
sid, trixie1.94.3-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fprintdsource(unstable)(unfixed)1072854

Notes

[bookworm] - fprintd <no-dsa> (Minor issue)
[bullseye] - fprintd <no-dsa> (Minor issue)
[buster] - fprintd <postponed> (Minor issue)
https://www.openwall.com/lists/oss-security/2024/05/30/3
https://lists.freedesktop.org/archives/fprint/2024-May/001231.html

Search for package or bug name: Reporting problems