CVE-2024-39614

NameCVE-2024-39614
DescriptionAn issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. get_supported_language_variant() was subject to a potential denial-of-service attack when used with very long strings containing specific characters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1076069

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)bullseye (security), bullseye2:2.2.28-1~deb11u2vulnerable
bookworm, bookworm (security)3:3.2.19-1+deb12u1vulnerable
sid, trixie3:4.2.14-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosource(unstable)3:4.2.14-11076069

Notes

https://www.djangoproject.com/weblog/2024/jul/09/security-releases/
https://github.com/django/django/commit/17358fb35fb7217423d4c4877ccb6d1a3a40b1c3 (4.2.14)

Search for package or bug name: Reporting problems