CVE-2024-39689

NameCVE-2024-39689
DescriptionCertifi is a curated collection of Root Certificates for validating the trustworthiness of SSL certificates while verifying the identity of TLS hosts. Certifi starting in 2021.05.30 and prior to 2024.07.4 recognized root certificates from `GLOBALTRUST`. Certifi 2024.07.04 removes root certificates from `GLOBALTRUST` from the root store. These are in the process of being removed from Mozilla's trust store. `GLOBALTRUST`'s root certificates are being removed pursuant to an investigation which identified "long-running and unresolved compliance issues."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-certifi (PTS)bullseye2020.6.20-1vulnerable
bookworm2022.9.24-1vulnerable
sid, trixie2024.6.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-certifisource(unstable)(unfixed)unimportant

Notes

https://github.com/certifi/python-certifi/security/advisories/GHSA-248v-346w-9cwc
Debian's python-certifi is patched to return the location of Debian-provided CA certificates

Search for package or bug name: Reporting problems