CVE-2024-5187

NameCVE-2024-5187
DescriptionA vulnerability in the `download_model_with_test_data` function of the onnx/onnx framework, version 1.16.0, allows for arbitrary file overwrite due to inadequate prevention of path traversal attacks in malicious tar files. This vulnerability enables attackers to overwrite any file on the system, potentially leading to remote code execution, deletion of system, personal, or application files, thus impacting the integrity and availability of the system. The issue arises from the function's handling of tar file extraction without performing security checks on the paths within the tar file, as demonstrated by the ability to overwrite the `/home/kali/.ssh/authorized_keys` file by specifying an absolute path in the malicious tar file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
onnx (PTS)bullseye1.7.0+dfsg-3vulnerable
bookworm1.12.0-2vulnerable
sid, trixie1.14.1-2.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
onnxsource(unstable)(unfixed)

Notes

[bookworm] - onnx <no-dsa> (Minor issue)
[bullseye] - onnx <no-dsa> (Minor issue)
https://huntr.com/bounties/50235ebd-3410-4ada-b064-1a648e11237e
https://github.com/onnx/onnx/pull/6164

Search for package or bug name: Reporting problems