CVE-2024-5629

NameCVE-2024-5629
DescriptionAn out-of-bounds read in the 'bson' module of PyMongo 4.6.2 or earlier allows deserialization of malformed BSON provided by a Server to raise an exception which may contain arbitrary application memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pymongo (PTS)buster3.7.1-1.1vulnerable
trixie, bookworm, bullseye3.11.0-1vulnerable
sid4.7.3-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pymongosource(unstable)(unfixed)

Notes

https://jira.mongodb.org/browse/PYTHON-4305
https://github.com/mongodb/mongo-python-driver/pull/1564

Search for package or bug name: Reporting problems