CVE-2024-5834

NameCVE-2024-5834
DescriptionInappropriate implementation in Dawn in Google Chrome prior to 126.0.6478.54 allowed a remote attacker to execute arbitrary code via a crafted HTML page. (Chromium security severity: High)
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5710-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium (PTS)bullseye (security), bullseye120.0.6099.224-1~deb11u1vulnerable
bookworm121.0.6167.139-1~deb12u1vulnerable
bookworm (security)126.0.6478.182-1~deb12u1fixed
trixie126.0.6478.126-1~deb13u1fixed
sid126.0.6478.182-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromiumsourcebuster(unfixed)end-of-life
chromiumsourcebullseye(unfixed)end-of-life
chromiumsourcebookworm126.0.6478.56-1~deb12u1DSA-5710-1
chromiumsource(unstable)126.0.6478.56-1

Notes

[bullseye] - chromium <end-of-life> (see #1061268)
[buster] - chromium <end-of-life> (see DSA 5046)

Search for package or bug name: Reporting problems