CVE-2024-6126

NameCVE-2024-6126
DescriptionA flaw was found in the cockpit package. This flaw allows an authenticated user to kill any process when enabling the pam_env's user_readenv option, which leads to a denial of service (DoS) attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cockpit (PTS)bullseye239-1vulnerable
bookworm, bookworm (security)287.1-0+deb12u2vulnerable
sid, trixie321-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cockpitsource(unstable)320-1

Notes

[bookworm] - cockpit <no-dsa> (Minor issue)
[bullseye] - cockpit <no-dsa> (Minor issue)
Fixed by: https://github.com/cockpit-project/cockpit/commit/08965365ac311f906a520cbf65427742d5f84ba4 (320)
https://bugzilla.redhat.com/show_bug.cgi?id=2292897
https://bugzilla.redhat.com/show_bug.cgi?id=2290859

Search for package or bug name: Reporting problems