CVE-2024-6387

NameCVE-2024-6387
DescriptionA security regression (CVE-2006-5051) was discovered in OpenSSH's server (sshd). There is a race condition which can lead sshd to handle some signals in an unsafe manner. An unauthenticated, remote attacker may be able to trigger it by failing to authenticate within a set time period.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5724-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssh (PTS)bullseye (security), bullseye1:8.4p1-5+deb11u3fixed
bookworm1:9.2p1-2+deb12u2vulnerable
bookworm (security)1:9.2p1-2+deb12u3fixed
sid, trixie1:9.7p1-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensshsourcebullseye(not affected)
opensshsourcebookworm1:9.2p1-2+deb12u3DSA-5724-1
opensshsource(unstable)1:9.7p1-7

Notes

[bullseye] - openssh <not-affected> (Vulnerable code introduced later)
Introduced with: https://github.com/openssh/openssh-portable/commit/752250caabda3dd24635503c4cd689b32a650794 (V_8_5_P1)
Fixed by: https://github.com/openssh/openssh-portable/commit/81c1099d22b81ebfd20a334ce986c4f753b0db29 (V_9_8_P1)
https://lists.mindrot.org/pipermail/openssh-unix-announce/2024-July/000158.html
https://www.openwall.com/lists/oss-security/2024/07/01/1
https://www.qualys.com/2024/07/01/cve-2024-6387/regresshion.txt

Search for package or bug name: Reporting problems