CVE-2025-47935

NameCVE-2025-47935
DescriptionMulter is a node.js middleware for handling `multipart/form-data`. Versions prior to 2.0.0 are vulnerable to a resource exhaustion and memory leak issue due to improper stream handling. When the HTTP request stream emits an error, the internal `busboy` stream is not closed, violating Node.js stream safety guidance. This leads to unclosed streams accumulating over time, consuming memory and file descriptors. Under sustained or repeated failure conditions, this can result in denial of service, requiring manual server restarts to recover. All users of Multer handling file uploads are potentially impacted. Users should upgrade to 2.0.0 to receive a patch. No known workarounds are available.
SourceCVE (at NVD; CERT, ENISA, LWN, oss-sec, fulldisc, Debian ELTS, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-multer (PTS)forky2.4.0+~cs3.2.0-1fixed
sid2.5.0+~cs3.3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-multersource(unstable)(not affected)

Notes

- node-multer <not-affected> (Fixed before initial upload to Debian)
https://github.com/expressjs/multer/security/advisories/GHSA-44fp-w29j-9vj5
https://github.com/expressjs/multer/pull/1120
Fixed by: https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665 (v2.0.0)

Search for package or bug name: Reporting problems