CVE-2025-47944

NameCVE-2025-47944
DescriptionMulter is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.
SourceCVE (at NVD; CERT, ENISA, LWN, oss-sec, fulldisc, Debian ELTS, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-multer (PTS)forky2.4.0+~cs3.2.0-1fixed
sid2.5.0+~cs3.3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-multersource(unstable)(not affected)

Notes

- node-multer <not-affected> (Fixed before initial upload to Debian)
https://github.com/expressjs/multer/security/advisories/GHSA-4pg4-qvpc-4q3h
https://github.com/expressjs/multer/pull/1120
Fixed by: https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665 (v2.0.0)

Search for package or bug name: Reporting problems