CVE-2025-7338

NameCVE-2025-7338
DescriptionMulter is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.2 to receive a patch. No known workarounds are available.
SourceCVE (at NVD; CERT, ENISA, LWN, oss-sec, fulldisc, Debian ELTS, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-multer (PTS)forky2.4.0+~cs3.2.0-1fixed
sid2.5.0+~cs3.3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-multersource(unstable)(not affected)

Notes

- node-multer <not-affected> (Fixed before initial upload to Debian)
https://github.com/expressjs/multer/security/advisories/GHSA-fjgf-rc76-4x9p
Fixed by: https://github.com/expressjs/multer/commit/adfeaf669f0e7fe953eab191a762164a452d143b (v2.0.2)

Search for package or bug name: Reporting problems