CVE-2026-106443

NameCVE-2026-106443
DescriptionWeasyPrint helps web developers to create PDF documents. Prior to 70.0, the image-loading path in weasyprint/images.py passes fetched image bytes from HTML img URLs, CSS image values, SVG image references, and data URIs to Pillow's generic image dispatcher without excluding EPS or PostScript formats. On hosts with Ghostscript installed, Pillow EpsImagePlugin invokes the interpreter for attacker-controlled PostScript, which can produce interpreter-permitted effects and can lead to remote code execution when the installed Ghostscript version has a usable sandbox bypass. Hosts without Ghostscript do not reach this rasterization path. This issue is fixed in version 70.0.
SourceCVE (at NVD; CERT, ENISA, LWN, oss-sec, fulldisc, Debian ELTS, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1150245

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
weasyprint (PTS)bookworm57.2-1vulnerable
trixie62.3-1vulnerable
forky, sid70.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
weasyprintsource(unstable)70.0-1unimportant1150245

Notes

https://github.com/Kozea/WeasyPrint/security/advisories/GHSA-r543-q48m-4c9j
Fixed by: https://github.com/Kozea/WeasyPrint/commit/39cd37ce1610bd890388e26591c569db1cbab542 (v70.0)
Not a security issue in weasyprint per se, just hardening against Ghostscript security issues
which are fixed in Debian anyway

Search for package or bug name: Reporting problems