| Name | CVE-2026-109399 |
| Description | SWUpdate through 2026.05.1 contains an improper certificate validation vulnerability in crypto/swupdate_cms_verify_openssl.c that trusts untrusted X.509 certificates embedded in CMS SignedData for chain building. Attackers holding a signing key from a sibling intermediate under the same root can embed that intermediate in the signature to install malicious updates. |
| Source | CVE (at NVD; CERT, ENISA, LWN, oss-sec, fulldisc, Debian ELTS, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more) |
| References | DLA-4864-1 |
Vulnerable and fixed packages
The table below lists information on source packages.
| Source Package | Release | Version | Status |
|---|
| swupdate (PTS) | bookworm | 2022.12+dfsg-4+deb12u2 | vulnerable |
| bookworm (security) | 2022.12+dfsg-4+deb12u3 | fixed |
| trixie | 2024.12.1+dfsg-3+deb13u2 | fixed |
| forky, sid | 2026.05.1+git20261001+dfsg-2 | fixed |
The information below is based on the following data on fixed versions.
| Package | Type | Release | Fixed Version | Urgency | Origin | Debian Bugs |
|---|
| swupdate | source | bookworm | 2022.12+dfsg-4+deb12u3 | | DLA-4864-1 | |
| swupdate | source | trixie | (not affected) | | | |
| swupdate | source | (unstable) | 2026.05+dfsg-1 | | | |
Notes
[trixie] - swupdate <not-affected> (swupdate in Trixie builds with WolfSSL calls wolfSSL_X509_STORE_CTX_init with untrusted intermediates set to NULL)
https://groups.google.com/g/swupdate/c/dsoMcGFnEns
https://github.com/sbabic/swupdate/commit/e66c5640664a31668926a24c0c84b6b6570dc0d9 (2026.05)