CVE-2026-112899

NameCVE-2026-112899
DescriptionPillow is a Python imaging library. In versions 2.3.0 through 12.3.0, EPS rendering does not validate the scaled image dimensions before invoking Ghostscript. Applications that process untrusted EPS or PostScript files using an application-selected scale greater than one can incur excessive Ghostscript CPU and temporary disk consumption. In versions with decompression-bomb protection, the scaled output is checked only after Ghostscript has completed rendering, allowing resource consumption beyond the configured pixel limit. The amplification depends on the scale selected by the application, not an attacker-controlled scale value. This issue is fixed in version 13.0.0.
SourceCVE (at NVD; CERT, ENISA, LWN, oss-sec, fulldisc, Debian ELTS, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)bookworm, bookworm (security)9.4.0-1.1+deb12u1vulnerable
trixie11.1.0-5+deb13u4vulnerable
trixie (security)11.1.0-5+deb13u3vulnerable
forky12.3.0-1vulnerable
sid13.0.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsource(unstable)13.0.0-1

Notes

https://github.com/python-pillow/Pillow/security/advisories/GHSA-vx6w-vv9f-6gvg
https://github.com/python-pillow/Pillow/pull/10112
Fixed by: https://github.com/python-pillow/Pillow/commit/3e8cc105588d1dfe062fcada0b6058c1b5f14b65 (13.0.0)

Search for package or bug name: Reporting problems