CVE-2026-118258

NameCVE-2026-118258
Descriptioni18next-http-backend is a backend layer for i18next that loads translation resources in Node.js, browsers, and Deno. Prior to 4.0.4, interpolateUrl inserts unencoded language and namespace values into loadPath or addPath templates without rejecting ampersand (&), equals (=), or semicolon (;) query separators. When a template places lng or ns in the query string and an attacker controls that value, the attacker can add or override parameters on browser or server-side translation requests, potentially exposing other namespaces or tenants or changing backend behavior through the application's network position and credentials. This vulnerability is the result of an incomplete fix for CVE-2026-41691. This issue is fixed in version 4.0.4.
SourceCVE (at NVD; CERT, ENISA, LWN, oss-sec, fulldisc, Debian ELTS, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-i18next-http-backend (PTS)bookworm2.1.1-1fixed
forky, sid, trixie2.4.1+ds-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-i18next-http-backendsource(unstable)(not affected)

Notes

- node-i18next-http-backend <not-affected> (Incomplete fix for CVE-2026-41691 not applied)
https://github.com/i18next/i18next-http-backend/security/advisories/GHSA-3cmx-xjww-583x
Fixed by: https://github.com/i18next/i18next-http-backend/commit/b0eef9efd425055c554787cef7f878de33bbf510 (v4.0.4)
CVE exists because of an incomplete fix for CVE-2026-41691 / GHSA-q89c-q3h5-w34g

Search for package or bug name: Reporting problems