CVE-2026-119207

NameCVE-2026-119207
Descriptionpypdf is a free and open-source pure-python PDF library. Prior to 6.21.3, pypdf can consume excessive memory when strict mode loads a crafted invalid PDF dictionary. Nested parsing failures add repeated exception text to newly raised errors, allowing a small malformed dictionary to amplify into very large error messages. This issue is fixed in version 6.21.3.
SourceCVE (at NVD; CERT, ENISA, LWN, oss-sec, fulldisc, Debian ELTS, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pypdf (PTS)bookworm3.4.1-1+deb12u1vulnerable
trixie5.4.0-1vulnerable
forky, sid6.21.1-1vulnerable
pypdf2 (PTS)bookworm2.12.1-3+deb12u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pypdfsource(unstable)(unfixed)
pypdf2source(unstable)(unfixed)

Notes

https://github.com/py-pdf/pypdf/security/advisories/GHSA-4vqv-7265-gm2w
https://github.com/py-pdf/pypdf/pull/4265
Fixed by: https://github.com/py-pdf/pypdf/commit/64270258c0eced720f7960aecf8cef31afd39f8d (6.21.3)

Search for package or bug name: Reporting problems