| Name | CVE-2026-22036 |
| Description | Undici is an HTTP/1.1 client for Node.js. Prior to 7.18.0 and 6.23.0, the number of links in the decompression chain is unbounded and the default maxHeaderSize allows a malicious server to insert thousands compression steps leading to high CPU usage and excessive memory allocation. This vulnerability is fixed in 7.18.0 and 6.23.0. |
| Source | CVE (at NVD; CERT, ENISA, LWN, oss-sec, fulldisc, Debian ELTS, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more) |
| Debian Bugs | 1125679 |
The table below lists information on source packages.
| Source Package | Release | Version | Status |
|---|---|---|---|
| node-undici (PTS) | bookworm | 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4 | vulnerable |
| bookworm (security) | 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3 | vulnerable | |
| trixie | 7.3.0+dfsg1+~cs24.12.11-1 | vulnerable | |
| forky | 8.10.2+dfsg+~cs3.2.2-1 | fixed | |
| sid | 8.12.2+dfsg+~cs3.2.3-2 | fixed |
The information below is based on the following data on fixed versions.
| Package | Type | Release | Fixed Version | Urgency | Origin | Debian Bugs |
|---|---|---|---|---|---|---|
| node-undici | source | (unstable) | 7.18.2+dfsg+~cs3.2.0-1 | 1125679 |
[trixie] - node-undici <no-dsa> (Minor issue)
[bookworm] - node-undici <no-dsa> (Minor issue)
https://github.com/nodejs/undici/security/advisories/GHSA-g9mf-h72j-4rw9
Fixed by: https://github.com/nodejs/undici/commit/b04e3cbb569c1596f86c108e9b52c79d8475dcb3 (v7.18.2)