CVE-2026-3520

NameCVE-2026-3520
DescriptionMulter is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.1 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing stack overflow. Users should upgrade to version 2.1.1 to receive a patch. No known workarounds are available.
SourceCVE (at NVD; CERT, ENISA, LWN, oss-sec, fulldisc, Debian ELTS, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-multer (PTS)forky2.4.0+~cs3.2.0-1fixed
sid2.5.0+~cs3.3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-multersource(unstable)(not affected)

Notes

- node-multer <not-affected> (Fixed before initial upload to Debian)
https://github.com/expressjs/multer/security/advisories/GHSA-5528-5vmv-3xc2
Fixed by: https://github.com/expressjs/multer/commit/7e66481f8b2e6c54b982b34c152479e096ce2752 (v2.1.1)

Search for package or bug name: Reporting problems