CVE-2026-92415

NameCVE-2026-92415
Description— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client. A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation. Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected. Category: unsafe reflection on wire data (HIGH). This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17. Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.
SourceCVE (at NVD; CERT, ENISA, LWN, oss-sec, fulldisc, Debian ELTS, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1150343

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jackrabbit (PTS)bookworm2.20.3-1vulnerable
forky, sid, trixie2.20.11-1.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jackrabbitsource(unstable)(unfixed)1150343

Notes

[trixie] - jackrabbit <no-dsa> (Minor issue)
[bookworm] - jackrabbit <postponed> (Minor issue)
https://www.openwall.com/lists/oss-security/2026/10/07/28

Search for package or bug name: Reporting problems