TEMP-0000000-54045E

NameTEMP-0000000-54045E
Descriptionmore to CVE-2015-2059
SourceAutomatically generated temporary name. Not for external reference.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libidn (PTS)wheezy1.25-2vulnerable
wheezy (security)1.25-2+deb7u3fixed
jessie (security), jessie1.29-1+deb8u2fixed
stretch1.33-1fixed
buster, sid1.33-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libidnsource(unstable)1.32-1
libidnsourcejessie1.29-1+deb8u1
libidnsourcesqueeze1.15-2+deb6u2
libidnsourcewheezy1.25-2+deb7u1

Notes

Introduced by fix for CVE-2015-2059
https://lists.gnu.org/archive/html/help-libidn/2015-07/msg00026.html
Patch: http://git.savannah.gnu.org/cgit/libidn.git/commit/?id=58c721ac2dc96bccd737f3f544f3a22a50477bbf
Testcase: http://git.savannah.gnu.org/cgit/libidn.git/commit/?id=c261018477f971d274dee305d27f8bff4afd4238
squeeze-tagged entry as temporary workaround until CVE assigned for issue solved in DLA-291-1

Search for package or bug name: Reporting problems