TEMP-1036689-1CA7FB

NameTEMP-1036689-1CA7FB
DescriptionBlock themes parsing shortcodes in user-generated data
SourceAutomatically generated temporary name. Not for external reference.
Debian Bugs1036689

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)buster5.0.15+dfsg1-0+deb10u1fixed
buster (security)5.0.21+dfsg1-0+deb10u1fixed
bullseye (security), bullseye5.7.8+dfsg1-0+deb11u2fixed
bookworm6.1.1+dfsg1-1vulnerable
sid, trixie6.5+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcebuster(not affected)
wordpresssourcebullseye(not affected)
wordpresssource(unstable)6.2.2+dfsg1-11036689

Notes

[bookworm] - wordpress <postponed> (Minor issue, fix along in future update)
[bullseye] - wordpress <not-affected> (Block template support was introduced later)
[buster] - wordpress <not-affected> (Block template support was introduced later)
https://wordpress.org/news/2023/05/wordpress-6-2-2-security-release/
https://github.com/WordPress/WordPress/commit/6a077b35f15590a843ff8a6c97a135f3a34872dd
Upstream reverted the change because it broke countless wordpress installations
https://github.com/WordPress/WordPress/commit/2bb3a5169548d16173cf48ca9da1111efc428f86

Search for package or bug name: Reporting problems