Information on source package newlib

Available versions

ReleaseVersion
stretch2.4.0.20160527-2
buster3.1.0.20181231-1
bullseye3.3.0-1
sid3.3.0-1

Open issues

BugstretchbusterbullseyesidDescription
CVE-2021-3420vulnerable (no DSA)vulnerable (no DSA)vulnerable (no DSA)vulnerableA flaw was found in newlib in versions prior to 4.0.0. Improper overfl ...
CVE-2019-14878vulnerable (no DSA)vulnerable (no DSA)fixedfixedIn the __d2b function of the newlib libc library, all versions prior t ...
CVE-2019-14877vulnerable (no DSA)vulnerable (no DSA)fixedfixedIn the __mdiff function of the newlib libc library, all versions prior ...
CVE-2019-14876vulnerable (no DSA)vulnerable (no DSA)fixedfixedIn the __lshift function of the newlib libc library, all versions prio ...
CVE-2019-14875vulnerable (no DSA)vulnerable (no DSA)fixedfixedIn the __multiply function of the newlib libc library, all versions pr ...
CVE-2019-14874vulnerable (no DSA)vulnerable (no DSA)fixedfixedIn the __i2b function of the newlib libc library, all versions prior t ...
CVE-2019-14873vulnerable (no DSA)vulnerable (no DSA)fixedfixedIn the __multadd function of the newlib libc library, prior to version ...
CVE-2019-14872vulnerable (no DSA)vulnerable (no DSA)fixedfixedThe _dtoa_r function of the newlib libc library, prior to version 3.3. ...
CVE-2019-14871vulnerable (no DSA)vulnerable (no DSA)fixedfixedThe REENT_CHECK macro (see newlib/libc/include/sys/reent.h) as used by ...

Resolved issues

BugDescription
CVE-2015-2305Integer overflow in the regcomp implementation in the Henry Spencer BS ...

Search for package or bug name: Reporting problems