Information on source package python3.2

Available versions

ReleaseVersion
wheezy3.2.3-7
wheezy (security)3.2.3-7+deb7u1

Open issues

BugwheezyDescription
CVE-2014-9365vulnerable (no DSA)The HTTP clients in the (1) httplib, (2) urllib, (3) urllib2, and (4) ...
CVE-2014-4650vulnerable (no DSA)
CVE-2014-4616vulnerable (no DSA)Array index error in the scanstring function in the _json module in ...
CVE-2014-2667vulnerable (no DSA)Race condition in the _get_masked_mode function in Lib/os.py in Python ...
CVE-2014-1912vulnerable (no DSA)Buffer overflow in the socket.recvfrom_into function in ...
CVE-2013-7440vulnerable (no DSA)The ssl.match_hostname function in CPython (aka Python) before 2.7.9 ...
CVE-2013-7338vulnerable (no DSA)Python before 3.3.4 RC1 allows remote attackers to cause a denial of ...
CVE-2013-4238vulnerable (no DSA)The ssl.match_hostname function in the SSL module in Python 2.6 ...
CVE-2013-2099vulnerable (no DSA)Algorithmic complexity vulnerability in the ssl.match_hostname ...
CVE-2013-1753vulnerable (no DSA)
CVE-2013-1752vulnerable (no DSA)

Open unimportant issues

BugwheezyDescription
CVE-2016-1000110vulnerable
CVE-2013-7040vulnerablePython 2.7 before 3.4 only uses the last eight bits of the prefix to ...
CVE-2010-3492vulnerableThe asyncore module in Python before 3.2 does not properly handle ...

Resolved issues

BugDescription
CVE-2016-0772The smtplib library in CPython (aka Python) before 2.7.12, 3.x before ...
CVE-2012-2135The utf-16 decoder in Python 3.1 through 3.3 does not update the ...
CVE-2012-1150Python before 2.6.8, 2.7.x before 2.7.3, 3.x before 3.1.5, and 3.2.x ...
CVE-2012-0845SimpleXMLRPCServer.py in SimpleXMLRPCServer in Python before 2.6.8, ...
CVE-2011-3389The SSL protocol, as used in certain configurations in Microsoft ...
CVE-2011-1521The urllib and urllib2 modules in Python 2.x before 2.7.2 and 3.x ...

Security announcements

DSA / DLADescription
DLA-871-1python3.2 - security update

Search for package or bug name: Reporting problems