Information on source package snort

Available versions

ReleaseVersion
stretch2.9.7.0-5
buster2.9.7.0-5
bullseye2.9.7.0-5
sid2.9.7.0-5

Resolved issues

BugDescription
TEMP-0328134-B819BCsnort: DoS in verbose mode
CVE-2009-3641Snort before 2.8.5.1, when the -v option is enabled, allows remote att ...
CVE-2008-1804preprocessors/spp_frag3.c in Sourcefire Snort before 2.8.1 does not pr ...
CVE-2007-1398The frag3 preprocessor in Snort 2.6.1.1, 2.6.1.2, and 2.7.0 beta, when ...
CVE-2007-0251Integer underflow in the DecodeGRE function in src/decode.c in Snort 2 ...
CVE-2006-6931Algorithmic complexity vulnerability in Snort before 2.6.1, during pre ...
CVE-2006-5276Stack-based buffer overflow in the DCE/RPC preprocessor in Snort befor ...
CVE-2006-2769The HTTP Inspect preprocessor (http_inspect) in Snort 2.4.0 through 2. ...
CVE-2006-0839The frag3 preprocessor in Sourcefire Snort 2.4.3 does not properly rea ...
CVE-2005-3252Stack-based buffer overflow in the Back Orifice (BO) preprocessor for ...
CVE-2004-2652The DecodeTCPOptions function in decode.c in Snort before 2.3.0, when ...
CVE-2003-0209Integer overflow in the TCP stream reassembly module (stream4) for Sno ...
CVE-2003-0033Buffer overflow in the RPC preprocessor for Snort 1.8 and 1.9.x before ...
CVE-2001-1558Unknown vulnerability in IP defragmenter (frag2) in Snort before 1.8.3 ...
CVE-2000-1226Snort 1.6, when running in straight ASCII packet logging mode or IDS m ...

Security announcements

DSA / DLADescription
DSA-297snort - integer overflow, buffer overflow

Search for package or bug name: Reporting problems