Information on source package squashfs-tools

Available versions

ReleaseVersion
stretch1:4.3-3+deb9u1
stretch (security)1:4.3-3+deb9u2
buster1:4.3-12
buster (security)1:4.3-12+deb10u1
bullseye1:4.4-2
bullseye (security)1:4.4-2+deb11u1
bookworm1:4.5-3
sid1:4.5-3

Open issues

BugstretchbusterbullseyebookwormsidDescription
CVE-2021-41072vulnerablevulnerablevulnerablefixedfixedsquashfs_opendir in unsquash-2.c in Squashfs-Tools 4.5 allows Director ...

Resolved issues

BugDescription
CVE-2021-40153squashfs_opendir in unsquash-1.c in Squashfs-Tools 4.5 stores the file ...
CVE-2015-4646(1) unsquash-1.c, (2) unsquash-2.c, (3) unsquash-3.c, and (4) unsquash ...
CVE-2015-4645Integer overflow in the read_fragment_table_4 function in unsquash-4.c ...
CVE-2012-4025Integer overflow in the queue_init function in unsquashfs.c in unsquas ...
CVE-2012-4024Stack-based buffer overflow in the get_component function in unsquashf ...

Security announcements

DSA / DLADescription
DSA-4967-1squashfs-tools - security update
DLA-2752-1squashfs-tools - security update

Search for package or bug name: Reporting problems