Information on source package xscreensaver

Available versions

ReleaseVersion
jessie5.30-1+deb8u2
jessie (security)5.30-1+deb8u1
stretch5.36-1
buster5.40-1
sid5.40-1

Resolved issues

BugDescription
TEMP-0539699-BC7A2Bxscreensaver: local screen lock bypassable via low resolution video devices
TEMP-0482385-09F6D5resizing the monitor with xrandr can crash xscreensaver
TEMP-0334193-23D83Axscreensaver does not maintain screen locks during upgrade
TEMP-0000000-4E21BAxscreensaver: symlink attack enables local information disclosure
CVE-2015-8025driver/subprocs.c in XScreenSaver before 5.34 does not properly ...
CVE-2011-2187
CVE-2010-3586Unspecified vulnerability in Oracle Solaris 9 allows local users to ...
CVE-2009-3101xscreensaver (aka Gnome-XScreenSaver) in Sun Solaris 10, and ...
CVE-2009-3100xscreensaver (aka Gnome-XScreenSaver) in Sun Solaris 9 and 10, ...
CVE-2007-5585xscreensaver 5.03 and earlier, when running without ...
CVE-2007-3283GNOME XScreenSaver in Sun Solaris 8 and 9 before 20070417, when root ...
CVE-2007-1859XScreenSaver 4.10, when using a remote directory service for ...
CVE-2004-2655rdesktop 1.3.1 with xscreensaver 4.14, and possibly other versions, ...
CVE-2003-1295Unspecified vulnerability in xscreensaver 4.12, and possibly other ...
CVE-2003-1294Xscreensaver before 4.15 creates temporary files insecurely in (1) ...
CVE-2003-0885Xscreensaver 4.14 contains certain debugging code that should have ...

Security announcements

DSA / DLADescription
DSA-3438-1xscreensaver - security update
DSA-3438-1xscreensaver - security update
DLA-338-1xscreensaver - security update

Search for package or bug name: Reporting problems