CVE-2001-1508

NameCVE-2001-1508
DescriptionBuffer overflow in lpstat in SCO OpenServer 5.0 through 5.0.6a allows local users to execute arbitrary code as group bin via a long command line argument.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)stretch2.2.1-8+deb9u6fixed
stretch (security)2.2.1-8+deb9u7fixed
buster2.2.10-6+deb10u4fixed
bullseye2.3.3op2-3+deb11u1fixed
bookworm, sid2.3.3op2-7fixed
lprng (PTS)stretch3.8.B-2.1fixed
buster3.8.B-2.2fixed
bookworm, bullseye, sid3.8.B-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cupssource(unstable)(not affected)
cupsyssource(unstable)(not affected)
lprngsource(unstable)(not affected)

Notes

- lprng <not-affected> (Not suid in Debian)
- cups <not-affected> (Not suid in Debian)
- cupsys <not-affected> (Not suid in Debian)

Search for package or bug name: Reporting problems