CVE-2002-0838

NameCVE-2002-0838
DescriptionBuffer overflow in (1) gv 3.5.8 and earlier, (2) gvv 1.0.2 and earlier, (3) ggv 1.99.90 and earlier, (4) gnome-gv, and (5) kghostview in kdegraphics 2.2.2 and earlier, allows attackers to execute arbitrary code via a malformed (a) PDF or (b) PostScript file, which is processed by an unsafe call to sscanf.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-176, DSA-179, DSA-182
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gv (PTS)wheezy1:3.7.3-1fixed
buster, sid, jessie, stretch1:3.7.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnome-gvsource(unstable)1.99.7-9medium
gnome-gvsourcewoody1.1.96-3.1mediumDSA-179
gvsource(unstable)1:3.5.8-27medium
gvsourcewoody3.5.8-26.1mediumDSA-176
kdegraphicssource(unstable)4:2.2.2-6.9medium
kdegraphicssourcewoody2.2.2-6.8mediumDSA-182

Search for package or bug name: Reporting problems