CVE-2002-1158

NameCVE-2002-1158
DescriptionBuffer overflow in the irw_through function for Canna 3.5b2 and earlier allows local users to execute arbitrary code as the bin user.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-224
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
canna (PTS)wheezy3.7p3-11fixed
jessie3.7p3-13fixed
stretch3.7p3-13.1fixed
buster, sid3.7p3-14fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cannasource(unstable)3.6p1-1high
cannasourcewoody3.5b2-46.2highDSA-224

Search for package or bug name: Reporting problems