CVE-2002-1384

NameCVE-2002-1384
DescriptionInteger overflow in pdftops, as used in Xpdf 2.01 and earlier, xpdf-i, and CUPS before 1.1.18, allows local users to execute arbitrary code via a ColorSpace entry with a large number of elements, as demonstrated by cups-pdf.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-222, DSA-226, DSA-232
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)stretch2.2.1-8+deb9u6fixed
stretch (security)2.2.1-8+deb9u2fixed
buster2.2.10-6+deb10u4fixed
bullseye2.3.3op2-3+deb11u1fixed
bookworm, sid2.3.3op2-7fixed
xpdf (PTS)stretch3.04-4fixed
buster3.04-13fixed
bullseye3.04+git20210103-3fixed
bookworm3.04+git20211001-1fixed
sid3.04+git20211021-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cupssource(unstable)1.1.18-1
cupsyssourcewoody1.1.14-4.3DSA-232
cupsyssource(unstable)1.1.18-1
xpdfsourcewoody1.00-3.1DSA-222
xpdfsource(unstable)2.01-2
xpdf-isource(unstable)2.01-2

Search for package or bug name: Reporting problems