CVE-2003-0033

NameCVE-2003-0033
DescriptionBuffer overflow in the RPC preprocessor for Snort 1.8 and 1.9.x before 1.9.1 allows remote attackers to execute arbitrary code via fragmented RPC packets.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-297
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
snort (PTS)wheezy2.9.2.2-3fixed
buster, sid, stretch2.9.7.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
snortsource(unstable)2.0.0-1high
snortsourcewoody1.8.4beta1-3.1highDSA-297

Search for package or bug name: Reporting problems