CVE-2003-0099

NameCVE-2003-0099
DescriptionMultiple buffer overflows in apcupsd before 3.8.6, and 3.10.x before 3.10.5, may allow attackers to cause a denial of service or execute arbitrary code, related to usage of the vsprintf function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-277
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apcupsd (PTS)wheezy3.14.10-2fixed
jessie3.14.12-1.1fixed
stretch3.14.14-0.3fixed
buster, sid3.14.14-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apcupsdsource(unstable)3.8.5-1.2high
apcupsdsourcewoody3.8.5-1.1.1highDSA-277

Search for package or bug name: Reporting problems