CVE-2003-0146

NameCVE-2003-0146
DescriptionMultiple vulnerabilities in NetPBM 9.20 and earlier, and possibly other versions, may allow remote attackers to cause a denial of service or execute arbitrary code via "maths overflow errors" such as (1) integer signedness errors or (2) integer overflows, which lead to buffer overflows.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-263
NVD severityhigh (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lpr (PTS)squeeze1:2008.05.17fixed
wheezy1:2008.05.17+nmu1fixed
jessie, sid1:2008.05.17.1fixed
netpbm-free (PTS)squeeze2:10.0-12.2fixed
wheezy2:10.0-15fixed
jessie, sid2:10.0-15.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lprsource(unstable)1:2000.05.07-4.20high
netpbm-freesource(unstable)2:9.20-9high
netpbm-freesourcewoody2:9.20-8.2highDSA-263

Search for package or bug name: Reporting problems