CVE-2003-0358

NameCVE-2003-0358
DescriptionBuffer overflow in (1) nethack 3.4.0 and earlier, and (2) falconseye 1.9.3 and earlier, which is based on nethack, allows local users to gain privileges via a long -s command line option.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-316, DSA-350
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nethack (PTS)wheezy3.4.3-14fixed
jessie3.4.3-15fixed
buster, sid, stretch3.6.0-4fixed
slashem (PTS)wheezy0.0.7E7F3-6fixed
jessie0.0.7E7F3-7fixed
buster, sid, stretch0.0.7E7F3-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
falconseyesource(unstable)1.9.3-9medium
falconseyesourcewoody1.9.3-7woody3mediumDSA-350
jnethacksource(unstable)1.1.5-15medium
nethacksource(unstable)3.4.1-1medium
nethacksourcewoody3.4.0-3.0woody3mediumDSA-316
slashemsource(unstable)0.0.6E4F8-6medium
slashemsourcewoody0.0.6E4F8-4.0woody3mediumDSA-316

Search for package or bug name: Reporting problems